Symptoms:
Starting a task of type Microsoft SQL Server may return a error with the following SQL-related exception message: Wrong format of the parameter value.
Cause:
This behavior can be observed on certain system cultures, including but possibly not limited to Turkish locale settings.
Workaround:
Change the culture of the service account (under which the DataHub Agent is running) to English.
This can be done via the following registry entry:
[HKEY_USERS\[USER-SID]\Control Panel\International]
"Locale"="00000409"
"LocaleName"="en-US"
where [USER-ID] ist the SID of the account that is used to run the Data Hub agent. In the default installation, the service runs as Local System account, for which the correct SID is S-1-5-18.
After applying the change, restart the service RayVentory Data Hub Agent.
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