RVY200794: Known Issue: RVIA Upload/Download getting an error message when using HTTPS connection

Affected versions: 

RayVentory Scan Engine

12.2:

12.2.2809.219 [SP3]

12.2.2810.220

12.2.3059.228 [SP4]

12.2.3069.236 [SP5]

12.2.3069.237

12.2.3070.238

12.3

12.3.3391.7 RTM

12.3.3394.15 [U01]

12.3.3429.24 [U02]

12.3.3431.39 [U03]

12.3.3449.44 [U04]

12.3.3510.47 [U05]

12.3.3510.49 [U06]

 

Symptoms:

When the RayVentory Inventory Agent is running the getconfig or upload command, the command fails with an error when the agent is configured to use HTTPS over SSL.

The error is:

curl: (56) Failure when receiving data from the peer

The download/upload however is processed successfully, but the exit code from curl doesn't reflect this, which leads to the getconfig and upload commands not finishing correctly.

This causes the getconfig command to not update the agent's scheduled tasks and it's registry values. And it causes the upload command to not delete files which have been uploaded to the RayVentory Scan Engine.

 

Cause:

The RayVentory Scan Engine HTTP Upload Server service is closing the SSL connection abruptly after the request from the agent has been handled.

 

Workaround:

To mitigate these issues, scheduled tasks can be created on the agent devices. A scheduled task can be used to regularly run the rvia schedule and rvia settings commands to update the agent's scheduled tasks and registry values. Another scheduled task can be used to regularly delete the old agent result files from C:\ProgramData\Raynet\RayVentoryInventoryAgent\results

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