RMS200491 Hotfix - RMS Messaging Client Service 1.2.6244.107 package fails to uninstall due to MSI error 1603

Problem

After removing the RMS Messaging Client Service from a policy, the managed devices fail to uninstall it after updating their machine policies due to a 1603 MSI error:  

MSI (s) (FC:90) [12:14:24:840]: Executing op: ActionStart(Name=CA_ExeCommand,,)
MSI (s) (FC:90) [12:14:24:840]: Executing op: CustomActionSchedule(Action=CA_ExeCommand,ActionType=3106,Source=C:\Windows\SysWOW64\,Target=sc config RmsClientService start= delayed-auto,)
MSI (s) (FC:90) [12:14:24:887]: Note: 1: 1722 2: CA_ExeCommand 3: C:\Windows\SysWOW64\ 4: sc config RmsClientService start= delayed-auto 
MSI (s) (FC:90) [12:14:24:887]: Note: 1: 2262 2: Error 3: -2147287038 
CustomAction CA_ExeCommand returned actual error code 1060 (note this may not be 100% accurate if translation happened inside sandbox)
MSI (s) (FC:90) [12:14:24:887]: Note: 1: 2262 2: Error 3: -2147287038 
MSI (s) (FC:90) [12:14:24:887]: Product: RmsClientService -- Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.  Action CA_ExeCommand, location: C:\Windows\SysWOW64\, command: sc config RmsClientService start= delayed-auto 
Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.  Action CA_ExeCommand, location: C:\Windows\SysWOW64\, command: sc config RmsClientService start= delayed-auto 
MSI (s) (FC:90) [12:14:24:903]: Note: 1: 2265 2:  3: -2147287035 
MSI (s) (FC:90) [12:14:24:903]: User policy value 'DisableRollback' is 0
MSI (s) (FC:90) [12:14:24:903]: Machine policy value 'DisableRollback' is 0
Action ended 12:14:24: InstallFinalize. Return value 3.

 

Cause

Defective custom action within the MSI.  

 

Resolution

  1. Receive the RMS Messaging Client Patch package
  2. Deploy the package with the "Automatically uninstall this application when it is no longer required by Deployment Manager policy." option active
  3. After ensuring the package has been deployed to ALL devices governed by the policy, the original RMS Messaging Client package and the Patch package can be removed from the policy 
  4. Check reporting for successful uninstall of both packages

 

Affected versions

RMS Messaging Client Service 1.2.6244.107

 

Notes

  • This fix has been included in the latest release of the RMS Messaging Client Patch package, version 11.0.0.9637 which can be obtained by right-clicking the Software snap-in and selecting 'Import... > Download and import support packages'.  
  • If version 1.2.6244.107 is already installed, then this articles resolution steps must first be carried out before a new version can be installed.  

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