Symptoms
While refreshing security errata in the ManageSoft Security Patch Manager console, the following error may be received:
---Problem--- (s0m0): A problem occurred while resolving the security digests into the database. Please report this issue immediately to ManageSoft support. Note that you may not be able to receive additional security bulletins until this issue is resolved.
---System exception--- Object reference not set to an instance of an object.
---Source--- ManageSoft.Packaging.SecurityPatch.Import
---Stack trace--- System.NullReferenceException: Object reference not set to an instance of an object. at ManageSoft.SecurityPatch.Database.API.DataLayer.SetVisibilityInSecurityPatchTable() at ManageSoft.SecurityPatch.Database.API.DataLayer.SetPatchOrBulletinsVisibility() at ManageSoft.Packaging.SecurityPatch.Import.SPM.UpdateErrata(String[] errataNames) at ManageSoft.PatchManager.ScopePane.SyncAllProgressDialog.DoOperation(IProgressCallback p_Progress)
In particular, the reference to the following method in the Stack trace section of the error shown above indicates that the problem described in this article as occurred:
ManageSoft.SecurityPatch.Database.API.DataLayer.SetVisibilityInSecurityPatchTable
Cause
This problem is caused by a logic error handling some types of changes to Microsoft Office security errata data that occurs when a bulletin/patch has previously been hidden but changes to the Security Patch Manager configuration are made which cause the bulletin/patch to no longer be hidden.
This problem can be worked around by executing the following query against the ManageSoft database:
UPDATE SecurityPatch
SET Ignore = 0
After executing this query, use the Security Patch Manager console to refresh the security errata again.
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