M100883: "Error 25000. An error occurred while configuring the ManageSoft database." reported while installing ManageSoft for Windows Deployment 7.9 with ManageSoft Deployment Manager 7.9.5

Symptoms

ManageSoft for Windows Deployment 7.9 reports the following error during installation of its database component if ManageSoft Deployment Manager 7.9.5 is installed:

Error 25000. An error occurred while configuring the ManageSoft database. Consult log files rolloutconfig-schema.log, rolloutconfig-ops.log, wimi-schema.log, HardwareAssessment-schema.log, RolloutGroups-schema.log, mgsWiMiPerms.log, mgsWimiProcedures.log, HardwareAssessment-ops.log, HardwareAssessment-views.log, site-schema.log, site-ops.log, imagelibrary-schema.log, imagelibrary-ops.log in ...\' for further information. Check your...

Logging in the file %TEMP%\mgsWiMiPerms.log shows:

Msg 1038, Level 15, State 4, Server <ServerName>, Line 1
An object or column name is missing or empty. For SELECT INTO statements, verify each column has a name. For other statements, look for empty alias names. Aliases defined as &quot&quot or [] are not allowed. Add a name or single space as the alias name.

Cause

This error message is caused by an incompatibility between the Windows Deployment&ampnbsp7.9 database setup routines and Deployment Manager&ampnbsp7.9.5.

Workaround

When the Error 25000 is reported by the ManageSoft for Windows Deployment install wizard, click OK to continue with the installation. Once the installation has been completed, run the following SQL query manually (replace <Scope> with the host name of the server itself unless the server is a Domain Controller, in which case use the NetBIOS domain of the Domain Controller.) using SQL Server Management Studio:

USE ManageSoft
GRANT INSERT, UPDATE, DELETE ON HardwareAssessmentCache TO [<Scope>\MGS Data Readers]

Be aware that other errors may be reported in the .log files mentioned in the error message displayed by the install wizard. You should manually scan through these log files to check for and respond to any other errors which have occurred in addition to the error covered by this article.

Additional information

This issue is described in the Deployment Manager 7.9.5 administration server release notes.

Status

ManageSoft has confirmed that this is a compatibility problem affecting Windows Deployment 7.9 used in conjunction with Deployment Manager 7.9.5.

"Could not load file or assembly 'DevExpress.Utils.v6.1..." error in console using ManageSoft for Windows Deployment 7.9 with ManageSoft Deployment Manager 7.9.5

Comments

Powered by Zendesk