Q205467: Deployment Manager package fails with exit code 3010

Symptoms

During installation or uninstallation you may receive an error similar to:
Command "C:\Program Files (x86)\Common Files\Microsoft Shared\OFFICE14\Office Setup Controller\setup.exe /uninstall STANDARD" returned exit code 3010

 

Cause

The MSI error code of 3010 occurs when Windows Installer needs to restart the machine to complete the task but is unable to do so. This is normally considered a warning however by default, non-zero exit codes are seen as a failure.

To resolve this you need to either enable the reboot option or tell the installer to ignore non-zero exit codes. You do this by:

For Deployment Manager versions prior to 10.0:
  1. Editing the package in Software Library in the admin console
  2. Expand External Installers then All External Installers
  3. Open the properties of the installer
  4. On the General tab, un-check the box for "Treat all non-zero installer return codes as errors"
For later versions:
  1. Editing the package in Software Library in the admin console
  2. Call the installers tab
  3. Edit the installer
  4. On the General tab, set the "Treat all non-zero installer return codes as errors" toggle switch to "No"
Save, Pack and re-distribute the package and the next time it runs the installation / uninstallation should complete.

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