M100805: Adoption error message: "Failure reason: The target device returned an error code"

The following article details common adoption failure causes and how to troubleshoot them. 

Symptoms

When viewing the status of an adoption job in the remote task manager, you see the following error message against a targeted device:

Failure reason: The target device returned an error code
The problem may be related to network name resolution. Ensure that the target device can resolve the host names specified in relevant distribution and reporting locations in your distribution hierarchy.

Command:
"\\ServerName\mgsRET$\Adoption\ndinstlr.exe" -r "http ://serverName/ManageSoftDL/Packages/ManageSoft
ManageSoft for Managed devices/7.72.6406/Rev1.0/
ManageSoft for managed devices/ManageSoft for managed devices.ndc" -o UserInteractionLevel=quiet
-o MsiInstallArgs="/L*v ManageSoft.msi.log DEPLOYSERVERURL=\\"http ://serverName/ManageSoftDL/ \" ALLUSERS=1 REBOOT=ReallySuppress POLICYSOURCE=Server COMPUTERDOMAIN=\\"domainName.com\" INSTALLMACHINEPOLICY=1 POLICYARGS=\\"-o InstallDefaultSchedule=TRUE -o UserInteractionLevel=quiet \""

Exit code: 1

Cause

When attempting to adopt a computer into management, the ManageSoft remote execution service runs an executable called ndinstlr.exe on the targeted device. This executable downloads and installs the appropriate ManageSoft package: ManageSoft for managed devices or ManageSoft for distribution servers. This executable encountered one of the following problems:

  • The download of the package to be installed (ManageSoft for managed devices or ManageSoft for distribution servers) has failed.
  • The Windows Installer (MSI) command to install ManageSoft for managed devices or ManageSoft for distribution servers failed.

Resolution

On the device that exhibits the failure, investigate the following:

  • The launcher.log or the installation.log file in the <windows>\temp\ManageSoft directory

    This file will show errors that ndinstlr.exe has encountered during the download of the package to be installed. Common error causes are:

    • DNS errors. 
      Please ensure that computer on which ManageSoft is to be installed, and the distribution server from which the package will be downloaded, can successfully perform ping and nslookups of each other.

    • The package to be installed has not been distributed to the distribution location that ndinstlr.exe is trying to download from.

    • Files in the ManageSoft for managed devices package contain MD5 errors, due to a file being manually replaced on the distribution location.

    • The path length for a file that is being downloaded as part of the ManageSoft for managed devices package is greater than 256 characters.

    • The wrong protocol for the distribution location has been configured. For example, HTTP is being used but the distribution location is configured for FILE.

    • The Windows Installer log in the <windows>\temp\ManageSoft\Cache\Common\ManageSoft for managed devices directory

      This file will contain error messages that have occurred when msiexec has tried to install the package. The following website may be useful in troubleshooting these problems:

      • MSDN: Error codes - Returned by MsiExec.exe or InstMsi.exe - These error codes are the values returned by Windows Installer (MSI) to ManageSoft after the package has been installed.

Further Troubleshooting

If further investigation for an adoption issue is required then please zip up the following files and send them to Support:

  • A screenshot of the adoption error that you are seeing on the administration server on the remote execution node.
  • From the computer on which installation is being attempted, a copy of the following:
    • All log files in the <windows>\temp\ManageSoft directory
    • A copy of the MSI log from ManageSoft for managed devices or ManageSoft for distribution servers install from <windows>\temp\ManageSoft\Cache\Common\<ManageSoft for managed devices OR ManageSoft for distribution servers> directory.   The log may also be in <windows>\temp or %TEMP%\ depending on which user account executed the installation.

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