Symptoms
This issue will most likely be identified from the policy / installation logs on the agent as it will show the URL it attempts to download the policy file from and will say that the file does not exist.
On investigating the location on the server you will see that the file doesn't exist but there is an entry in the Policy node for it.&nbsp This means that the policy file (*.npl) is not being created.
You may also see the following error in the logs or the distribution wizard:
On investigating the location on the server you will see that the file doesn't exist but there is an entry in the Policy node for it.&nbsp This means that the policy file (*.npl) is not being created.
You may also see the following error in the logs or the distribution wizard:
The policy merge did not generate policy files to distribute. This is because there are no users or computers targeted by the policy merge. Policy file "ManageSoft Policies" is missing from folder "D:\ManageSoft\Staging\Common\Policies\Archives". (s193m107)
Cause
This issue is caused because the PolicyDistributeQuery Stored Procedure has not been successfully updated during the upgrade.
This issue often occurs where the database is on a separate server and the upgrade was performed manually instead of using the installer as the mgsProcedures.sql file is only launched by the installer.
Resolution
First of all, manually execute the attached 'public_mgsProcedures.sql' file (for version 8.4.1 only) as this is the part of the upgrade that contains the PolicyDistributeQuery procedure.
Once this has completed please run the following from the command line:
<Program Files>\ManageSoft\Distributor\nddistrb -t Policy -d "[Distribution Location Full Name]" -a "DC=MANAGESOFT" -o PopulateDatabase=false
This will force the generation of ManageSoft npl files and then distribute them so that they are available for download. You can see this by checking <ManageSoftAppFolder>\Staging\Common\Policies... or <ManageSoftAppFolder>\LocalDeployment\Policies...
Additional Information
The [Distribution Location Full Name] can be found by:
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Expanding the Distribution node on the admin server
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Expand Distribution Servers
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Click on Distribution Locations
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Access the properties of Core Distribution Server
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[Distribution Location Full Name] is the complete value under 'Name'
The attached mgsProcedures.sql file is for 8.4.1, there is also an attached 'public_mgsProcedures822.zip' file for Deployment Manager 8.2. For all other versions that experience this issue please use the file from the installer download or KB for that version.
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