Symptoms
Huge values for the number of application sessions, active time and/or run time appear in application usage reports for devices running ManageSoft for managed devices 7.9 or 7.9 SP1. For example, you may see usage reports showing thousands of sessions, or numbers that correspond to many weeks, months or even years of active and run time of applications over the course of just one week.
The key symptom noticed on managed devices is the application usage agent uploading a new usage file (approximately) every 10 seconds on Mondays. That may lead to poor performance on the managed device (although typically the performance impact is negligible), a high load importing usage files on the administration server and/or a backlog of usage files to be imported.
Logging in the usage agent log (C:\WINDOWS\Temp\ManageSoft\usageagent.log) appears as follows while devices are in this state (notice the approximately 10&nbspsecond gap between uploads):
[2/25/2008 9:01:40 AM (G, 0)] {1924} Started uploading usage data [...] [2/25/2008 9:01:41 AM (G, 0)] {1924} Finished uploading usage data [...] [2/25/2008 9:01:52 AM (G, 0)] {1924} Started uploading usage data [...] [2/25/2008 9:01:52 AM (G, 0)] {1924} Finished uploading usage data
The problem of frequent uploads as described above only occurs intermittently (typically on less than 1%& of devices in any given week). However inspection of the usage agent log will always show activity backing up and summarizing the session cache every 10&nbspseconds on Mondays (whether or not uploads are also being done). Logging in this scenario shows the following activity approximately every 10 seconds:
[3/03/2008 9:27:39 AM (G, 0)] {1792} Started backing up the session cache [3/03/2008 9:27:39 AM (G, 0)] {1792} Finished backing up the session cache [3/03/2008 9:27:39 AM (G, 0)] {1792} Starting import of web data [3/03/2008 9:27:39 AM (G, 0)] {1792} Import of web data finished. [3/03/2008 9:27:39 AM (G, 0)] {1792} Started summarizing the session cache [3/03/2008 9:27:39 AM (G, 0)] {1792} Finished summarizing the session cache, no sessions to summarize
The only external impact of this behavior is a negligible amount of CPU usage on managed devices (typically this impact is not noticeable).
This problem persists until 12am Tuesday, at which time the 10 second cycle of session cache backups, summarizing, and uploads ceases.
The above description applies to the usage agent running on 7.9 and 7.9 SP1 managed devices. For ManageSoft for managed devices 7.9.2, the primary symptom of this problem is that the usage agent stops running at 12am on Monday mornings. The usage agent does not start running again until the computer is rebooted or the ManageSoft Security Service is restarted.
If a computer is running on Sunday and then suspended before 12am Monday, the problem is triggered as soon as the computer is resumed after being suspended if the computer is resumed at any time on Monday.
Cause
This problem is caused by a defect in the usage agent that is triggered when the current day of the week switches from Sunday to Monday.
Workaround
This problem can be worked around by arranging for the ManageSoft Security Service (named mgssecsvc) to be restarted at 12am on Mondays (or as soon as possible afterwards). The usage agent runs inside this service.
One way to achieve this is to:
- Deploy the RestartSecurityAgentServices.vbs script that is attached to this article below to all devices.
- Create an event in the machine schedule targeted to managed devices with a trigger to execute at 12am each Monday. The event should be configured with the type Run a Windows program, script or batch file, and have the option Run only the last event missed selected. Configure the event to execute the RestartSecurityAgentServices.vbs script. For example, configure the event with the following parameters:
Target: $(WinDirectory)\system32\wscript.exe
Parameters: "(ProgramFiles)\ManageSoft\RestartSecurityAgentService.vbs"
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Status
This problem has been confirmed as a known issue affecting ManageSoft for managed devices in Deployment Manager releases 7.9, 7.9 SP1 and 7.9.2. The problem has be
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